• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question Intermediate Boot order corrupted after installing Pop_Os

JohnnyS318

New member
Aug 23, 2020
1
0
4
18
I tried to install Pop Os alongside my Windows Os on my Acer Aspire 5 A515 52G. After a failed attempt and a clean wipe of my SSD, I followed the Guide on the official Pop_Os! Website. It states that Pop_Os should be installed first and that seemed a bit strange. But it is encouraged because in the Pop_Os installer a new EFI Partition has to be declared and formatted thus making a Windows first installation much more difficult.

After installing Pop_Os on my clean SSD, everything seemed to work fine and it did. But just like the first try, after visiting the UEFI the boot order was completely corrupted. The only item in the list was the prefix for the second boot entry, so just a 2., nothing else.
corrputed_uefi_boot_menu.jpg


But the good news is that the UEFI boots into Pop_Os correctly. Tho when I used the efibootmgr utility all boot items in the EFI partition, including the USB boot entry, were correctly discoverd.

The next step was to install Windows alongside Pop_Os. I prepared my USB stick with the Media Creation Tool but when I plugged it into the Laptop, it booted into Pop_Os on my internal SSD. When trying to open the UEFI menu, it does not open and just a white cursor in the top left corner appears.

corrupted_uefi.jpg


I could not set the boot order in the UEFI when the USB stick was not inserted because I have no boot order.

I tried setting the boot order from within linux with the efibootmgr utility, but after a restart the applied changes were dropped and the Laptop booted Pop_Os.

I thought it was a bug by the UEFI but Acer only gives a Windows Application to updated ones BIOS firmware and because I can't even get a live usb stick to boot that idea was dropped as well.

If anyone has any idea or had somewhat of a similar situation, it would make my day because I seriously can not take it any more and I am thinking about cleaning my SSD a second time and install Windows for the last time.
 
Last edited:

Members online

No members online now.

Latest projects

Forum statistics

Threads
1,465
Messages
6,646
Members
1,426
Latest member
calebgucciardi