• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Calculator Key Crash Gnome Session

jesseb

New member
Aug 10, 2020
4
0
4
39
All,
I recently made the change from Ubuntu to Pop!_OS and love it. I did notice one issue though. When using the calculator hot key on a keyboard, it appears to crash (or kill) the Gnome session. In others OSes, it launches the calculator app. I have tried searching and I have not found this previously reported.
I am using the black Microsoft Sculpt keyboard/mouse.

Sadly, I have pressed the key several times out of habit and killed my session.

Please let me know if there is any other information I can provide to help troubleshoot and/or resolve this issue.

Thank you,

Jes
 

TeamLinux01

Member
May 5, 2019
52
5
11
35
Have you tried remapping the key to "Launch calculator" under the Settings > Keyboard Shortcuts?
Just curious if that helps.
 

jesseb

New member
Aug 10, 2020
4
0
4
39
Thank you for the suggestion. I did try to map to the calculator, however, when it asks me to press the key to map, it against kills Gnome. I am going to try and do more research to see what the calculator key actually sends so I can see if that is assigned to an existing action that needs to be disabled first.
 

TeamLinux01

Member
May 5, 2019
52
5
11
35
I just tried ET-KG010 Keyboard with its calculator key on the Pop!_OS laptop at my desk.
It opened the calculator app without any additional configuration. It makes me think that it is a specific problem with that model keyboard.
 

jesseb

New member
Aug 10, 2020
4
0
4
39
Thank you for your feedback. It very well could be. It is a Microsoft keyboard and probably best used with Windows and could be limited to this make and model. I am no longer able to use regular keyboards due to hand pain and have been using the ergonomic keyboards from MS for several years. Worse case, I just need to break my habit of using that key. It would be one thing if it simply did nothing. The issues is that it kills the gnome sessions (similar to how CTL+ALT+Backspace was used in some editions).
 

jesseb

New member
Aug 10, 2020
4
0
4
39
I have confirmed that this issue seems to be limited to the Microsoft Sculpt Keyboard. The issue only occurs when pressing the calculator hot-key that is on the number pad. There is actually another calculator hot-key on the main keyboard section that appears to work fine. The issue is the one on the number pad is just too convenient :)
 

Members online

Latest projects

Forum statistics

Threads
1,109
Messages
5,109
Members
1,131
Latest member
ubu