• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question Advanced Display doesn't blank/sleep.

Hwaiting

New member
Dec 31, 2019
3
0
4
28
When the timer of the Blank Screen runs out (1min) the display slowly fades and then switches off; only for the display to be awakened again within seconds (to show the log-in screen). When another minute expires the screen is blanked instantly to wake almost instantly again.

IIRC on other distro's/ KDE+SDDM this used to repeat every minute till the Automatic Suspend timer runs out (15min), and the entire system goes to sleep. (Including display.)
With Pop/Gnome it repeats once, and then on the third try the screen stays on but does go gray using the same animation of the first blank attempt. This gray screen stays till the system sleeps.

What is keeping my display from sleeping?

It seems like the display gets a 'wake up' signal every second, but this signal does not keep the entire system awake (aka reset the suspend timer). I've had this problem for quite a while now, and it's not limited to Pop!_OS, (Manjaro and other ubuntu variants). Following is a list of troubleshooting I performed without success, and some system information:
  1. It's a desktop PC
  2. GFX: Rx480, connected to a Dell U2414H with a DP to HDMI cable
  3. I've disconnected all peripherals
  4. Disconnected ethernet cable
  5. 'xset display force off' or the suspend/standy variants. All instantly switch off the screen but none permanently. Adding a sleep timer before also doesn't help.
  6. I've tried monitoring for events in a terminal window but can't remember how tbh.
Anyone have an idea what I can do to investigate/fix this?
 

Hwaiting

New member
Dec 31, 2019
3
0
4
28
Oké something strange happened. (I changed the suspend/blank timings so they won't match with the OP.)

Last night I noticed that the screen had blanked, and remained asleep, even though the desktop remained on and did not suspend. Not wanting to ruin a good thing I left it like that for the night. This morning I tried suspending manually and the PC wouldn't. When I issued a reboot/shutdown command I saw that the log was being spammed by something (see below). This seemed to be inhibiting the suspend/shutdown. I had to forcefully shutdown the PC.

After waiting a moment before putting the PC back on, the log isn't being spammed anymore. The system has now returned to the state as in OP, with the screen not remaining blanked but the system suspending after that timeout.

This is what was (constantly) being spammed in the log:

Code:
Jan 02 09:46:20 [Hwaiting]-pc kernel: No Local Variables are initialized for Method [_L69]
Jan 02 09:46:20 [Hwaiting]-pc kernel: No Arguments are initialized for method [_L69]
Jan 02 09:46:20 [Hwaiting]-pc kernel: ACPI Error: Aborting method \_GPE._L69 due to previous error (AE_NOT_FOUND) (20190703/psparse-529)
Jan 02 09:46:20 [Hwaiting]-pc kernel: ACPI Error: AE_NOT_FOUND, while evaluating GPE method [_L69] (20190703/evgpe-511)
The only thing I can think of that I did/changed was manually switch off the display. Moving to troubleshoot now.

Edit:

Oké the display thing was a bit of a stretch. Can't reproduce.

E2:

This is getting frustrating. After the fiddling with screen on screen off above the blank and suspend worked perfectly. Thinking I had finally found a work around I rebooted and now I'm back to a screen that doesn't blank...
 
Last edited:

Members online

Latest projects

Forum statistics

Threads
858
Messages
3,913
Members
820
Latest member
alur222