• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.

Dual Boot with factory Windows 10 - Can not disable -format yes- selection upon selection of existing /boot/efi partition!?!?


New member
Apr 14, 2019
I experience a trouble with a Dell XPS 15 9570 with Windows 10 already installed, trying to install dual boot Pop!OS 18.10. I've shrunk the Windows partition. Using the Live Pop!OS installation, I have used GPARTD to create the root and swap partitions. when I select the /boot/efi partition that is already there, the installation wants to format it and I can not turn off the Format option! I can not change the formatting type either, if I remember correctly. Disk is using GPT partition table. Creating an additional Linux /boot/efi partition does not work, since it tries to install the Linux boot into the existing efi partition.

I had to turn on the BIOS option of legacy boot. Without it. system boots to a small one pixel dot in the top left corner and never continues.

Same results with CD-ROM or USB boot media. 18.10 version.

The only way I've found (from searching) to get around this is to completely erase the drive and try either installing Windows 10 again or start with Pop!OS installed first. Don't know what troubles I'll encounter doing it that way. I'm about ready to purchase another SSD to replace the one in the system and try this. I'd rather not. That is more money on something that depreciates quickly!

I'd like to keep all the original partitions that were installed from the factory - recovery, diagnostics, etc. AND Dual Boot Pop!OS instead of using VirtualBox or some other tool.

Any ideas what to try here?


Resolved this on 4-14-2019.
Used the 14.04 USB to install. Was able to use the existing EFI partition. Did not have the trouble of not being able to disable the Format option.
Then upgraded to 18.10.
The inconsistent Linux strikes again!
Last edited:

Members online

No members online now.

Latest posts

Latest projects

Forum statistics

Unanswered questions
Latest member