• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question Guide Guide to hibernate? (Answer is a guide)

thiagoaraujos

New member
Oct 17, 2020
17
1
4
38
Hi, I can't get hibernate to work. After following reasonable steps, I get the following error message:

Code:
$ sudo systemctl hibernate
Failed to hibernate system via logind: Not enough swap space for hibernation
My Pop!_OS version is the latest (COSMIC), with the latest updates.

My setup has the following characteristics:

- Encrypted root partition (LUKS)
- Encrypted home partition (LUKS)
- 64 GB RAM
- No swap partition (64 GB RAM exempts me from that)

I'm trying to set up a swapfile for hibernation in my home partition (/home/swapfile) because I only have enough space in that partition.

I check if my system supports hibernation, and it looks like it does (please correct me if I am wrong):

Code:
$ cat /sys/power/state
freeze mem disk
Now here are the commands I am running to set up a swap partition:

Code:
sudo fallocate -l 64G /home/swapfile
sudo chmod 600 /home/swapfile
sudo mkswap /home/swapfile
sudo swapon /home/swapfile
I added the following line to /etc/fstab

Code:
/home/swapfile none swap defaults 0 0
I check if the swap partition was added, and it was indeed:

Code:
$ cat /proc/swaps
Filename                                Type            Size            Used            Priority
/home/swapfile                          file            67108860        0               -2
Then I run filefrag to get resume_offset (output stripped):

Code:
$ sudo filefrag -v /home/swapfile
File size of /home/swapfile is 68719476736 (16777216 blocks of 4096 bytes)
ext:     logical_offset:        physical_offset: length:   expected: flags:
   0:        0..       0:   72785920..  72785920:      1:
....
From the output, I can see the offset is clearly 72785920. Ok, so now I proceed to adding the kernel parameters:

Code:
sudo kernelstub -a "resume=/dev/mapper/lvm-home resume_offset=72785920"
I also tried to resume=UUID (replacing UUID with the actual UUID of my home partition), delete the previous swapfile and redo all the swap steps from scratch to setup the new swapfile, but that did not work either.

I also created /etc/initramfs-tools/conf.d/resume with the following contents:

Code:
resume=/dev/mapper/lvm-home resume_offset=72785920
Then I run:

Code:
sudo update-initramfs -c -k all
Finally, I reboot successfully.

After all that, I get the "Not enough swap space for hibernation" message when running sudo systemctl hibernate.

Another thing I've tried is to create a swapfile with an arbitrary size of 90 GB (which is larger than my 64 GB of RAM - since it was complaining about not enough swap space) but I still get the same message.

Is there anything I'm doing wrong?

Thank you!
 
Last edited:

Members online

No members online now.

Latest projects

Forum statistics

Threads
1,486
Messages
6,712
Members
1,433
Latest member
ducky