• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Help with broken fstab / crypttab / EFI

confused_fish

New member
Apr 7, 2020
2
0
4
27
Hi all,

This is a copy of a post I made on the pop_os subreddit. I haven't had much (any) luck with responses there so hoping someone can help me here - I hope the dual posting accross sites is OK. If I get an answer here I will post a reply on the reddit post saying so and directing readers to this post (and vice versa).

Also apologies in advance if I've posted in the wrong sub-forum. I am by absolutely no means a sys admin / expert user, but I don;t think this query fits well into any of the other sub-forums on this site.

So without further ado:

I seem to have broken my Pop_OS install (nVidia 19.10) on a Thinkpad X1 Extreme.

Details:
  • Due to needing to run Windows for some applications I wiped my old Pop-only install, I installed Windows first on nvme1, but ensured the EFI partition was 1Gb to accommodate Pop. Partitions as:
Code:
nvme1n1p1 = EFI
nvme1n1p2 = Windows recovery or something (small, auto installed by Win)
nvme1n1p3 = Windows C
  • Then booted into a Pop live USB, setup a LUKS encrypted volume nvme1n1p4 for / and swap
  • I set up a separate LUKS volume on nvme0n1p1 for /home
  • With some difficulty I was able to get Pop to install in this configuration (having to install first with /home as a simple directory in /root and then redirecting /home to the to the actual /home lv setup on the second SSD once installed
This was all well and good until (at least I think until) I decided to change the names of the LUKS volumes in /etc/crypttab from whatever they were before (can't remember sorry) to "crypt-popos-main" for the volume on nvme1n1p4 and "crypt-popos-home" for the one on nvme0n1p1.After that Pop would not boot and instead I was dumped into initramfs.

How I tried to fix:
  • With a live USB and used the installer repair option (didn't work, kept failing)
  • Read up and realised the failed boot was due to me having not updating initramfs
  • Live USB again, luksOpen the volumes, mounted, chrooted and updated initramfs (FAILED)
  • Realised I have to actually luksOpen the volumes from the liveCD with the same name as I'd used in /etc/crypttab (i.e. "crypt-popos-root")
  • Live USB again, luksOpen the volumes, mounted, chrooted and updated initramfs (SUCCESS!)
However now I'm in a very odd scenario - PopOS prompts for the crypt password on bootup (but only if I press F12 after choosing the linux bootloader option to get to terminal text entry (sorry don;t know the proper phrase), the usual graphical password prompt - with the little hard disk icon to the left - doesn't work) HOWEVER, I cannot get to a login screen. After entering the correct password for the volume the screen goes black and I can't get any further :(

I have tried booting into the Live USB and updating the install on the SSD via chroot, updated all packages, cleaned apt etc, still no luck. I have also tried reading the boot logs in /var however the last log was from when the system was working, there are no recent logs.

If anyone knows what is going on or how I can resolve this I would be much obliged.

My crypttab looks like this:

Code:
crypt-popos-main UUID=ed26d35c-5f13-4511-8e42-635fe22f67ce none luks
crypt-popos-home UUID=35a41645-1581-4ee5-9370-5a08a872b4ac none luks
and my fstab looks like this:

Code:
PARTUUID=29682747-542d-4a59-9af5-82f57c678288  /boot/efi  vfat  umask=0077  0  0
/dev/mapper/vg--popos--main-lv--popos--data  none  / ext4  errors=remount-ro 0 1
/dev/mapper/vg--popos--main-lv--popos--swap  none  swap  defaults  0  0
I have been into the EFI partition and it looks a bit of a mess tbh, but I can boot into the linux bootloader and load Windows fine, so I think it's working correctly.
 

Members online

Latest projects

Forum statistics

Threads
858
Messages
3,912
Members
820
Latest member
alur222