• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Solved Installation Boot Failure.


Trusted User
Founding Member
Nov 23, 2018
One of my boxes has a weird quirk that is worth documenting. To all appearances, it's a boot failure that is remarkably similar to one involving Secure boot. In the last two to three years I’ve tested over 40 distros, some of which were installed multiple times when I fudged them up and reformatted, or the installer failed. The number of installations is more like 200, and distributed over five machines, so I have a good sample.

I’m not sure of the cause, but if it has any relevance the machine in question has an Intel i7 6700U chip on an Asus board. It was purchased as a Linux only machine which has never had Windows installed, so there are no actual Secure boot problems. No other computer I have behaves like this one, but after speaking with a colleague, it may be more prevalent as his machine does it also.

This machine refuses to actuate the quick boot override so to boot a live USB I have to change the boot order manually. I can install to HD from the live environment, and in the attempt to restart it fails due to the boot order not adapting. Shutting down, entering BIOS and manually changing the boot order to prioritize the HD is the only way this machine will start the operating system. Being new to Linux at the time, and not being familiar with a multitude of otherwise easily fixed boot errors, it took me a while to figure out. I was thrown because every other machine I had tried auto selects the HD when the USB is no longer attached.

Having experienced Secure boot installation failures and not knowing about this failure to auto-select the HD, I wasted a lot of time looking in the wrong place. It sounds like a new user problem, but you never know when you might overlook simple fixes. In any case, its documented now and hopefully a helpful option to explore if anyone is having a worry like this.


Founding Member
Jan 6, 2019
I was able to overcome Secure Boot issues on a Lenovo ideaPad 2-in-1 by simply nuking the EFI partition on the eMMC drive. Now it simply boots from any MBR-formatted USB device plugged into any USB port.

Which means if I try to use a USB stick for /home the system fails to boot, and I'm completely unable to enter the EFI configuration. You win some, you lose some I guess.

Members online

Latest posts

Latest projects

Forum statistics

Latest member