• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question Solved Installation issue on G20CB Asus Rog

JaegerW

New member
Nov 5, 2020
6
1
4
29
Hello everyone!

Let me get started with the fact that I am a fresh linux user who normally works on windows 10, so excuse my newbism.
I have been trying to install a few linux distros on this machine to no avail, where I have succesfully installed ubuntu on my laptop!
This system seems to be giving an issue when I try to get past the initial boot screen with multiple OSes.

I have tried to install popOS from a 32GB USB stick with Nvidia drivers (I assume as this was the iso i downloaded), and every time I launch into the install/ try mode I get a black screen. I have disabled fast boot and safe boot, but it doesnt seem to help. I get a lot of green OK's flying over my screen until I eventually reach the same page, the big black screen with nothing on it. My PC seems to be rather quiet when in this mode too.

Here are the specs of my PC, hopefully it helps as I am getting out of options :<
(sorry it's in dutch :) )

Naam van besturingssysteem Microsoft Windows 10 Home
Versie 10.0.19041 Build 19041
Andere beschrijving van besturingssysteem Niet beschikbaar
Leverancier van besturingssysteem Microsoft Corporation
Systeemnaam DESKTOP-EDSC22A
Systeemfabrikant ASUSTeK COMPUTER INC.
Systeemmodel G20CB
Systeemtype x64-based PC
Systeem-SKU SKU
Processor Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz, 3401 MHz, 4 core('s), 8 logische processor(s)
BIOS-versie/datum American Megatrends Inc. 2202, 16-3-2018
SMBIOS-versie 3.0
Versie van ingesloten controller 255.255
BIOS-modus UEFI
Basisbordfabrikant ASUSTeK COMPUTER INC.
Basisbordproduct G20CB
Basisbordversie Rev 1.xx
Platformfunctie Desktop
Status beveiligd opstarten Ingeschakeld
PCR7-configuratie Uitbreiding van bevoegdheden vereist om te kunnen weergeven
Map met Windows C:\Windows
Systeemmap C:\Windows\system32
Opstartapparaat \Device\HarddiskVolume3
Landinstelling Nederland
HAL (Hardware Abstraction Layer) Versie = "10.0.19041.488"
Gebruikersnaam
Tijdzone West-Europa (standaardtijd)
Geïnstalleerd fysiek geheugen (RAM) 32,0 GB
Totaal fysiek geheugen 31,9 GB
Beschikbaar fysiek geheugen 28,2 GB
Totaal virtueel geheugen 36,7 GB
Beschikbaar virtueel geheugen 30,7 GB
Ruimte voor wisselbestand 4,75 GB
Wisselbestand C:\pagefile.sys
DMA-beveiliging van kernel Uitgeschakeld
Beveiliging op basis van virtualisatie Niet ingeschakeld
Ondersteuning voor apparaatversleuteling Uitbreiding van bevoegdheden vereist om te kunnen weergeven
Hyper-V - Modusextensies VM-monitor Ja
Hyper-V - Extensies voor adresomzetting op tweede niveau Ja
Hyper-V - Virtualisatie ingeschakeld in firmware Ja
Hyper-V - Bescherming tegen gegevensuitvoering Ja


PS. I have tried a bit with Debian for example using the grub screen with some disables but I'm not sure I was doing stuff wrong as it seems quite vague.

Thank you for taking the time to help me out :)
 

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,911
325
30
www.patreon.com
See if there's any firmware updates for your BIOS.
Did you try 20.04LTS or 20.10? Being a little older your machine may require the 20.04LTS which has a slightly older kernel version.
There's also this article that explains some common mistakes and issues.
 
  • Like
Reactions: JaegerW

JaegerW

New member
Nov 5, 2020
6
1
4
29
Hi derpOmattic,

Thanks for your reply! I'll see if I can update my BIOS and then move on to an LTS installation and see if that works.

Edit: IT WORKED! Thanks to derpOmattic's guide! Apparently I wasnt reading too much into the BIOS menu but the Legacy boot was not disabled :) thank you again!
 
Last edited:
  • Like
Reactions: derpOmattic

Members online

No members online now.

Latest posts

Latest projects

Forum statistics

Threads
1,495
Messages
6,733
Members
1,433
Latest member
denis_vasconcelos