• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question Installing Pop!_OS failed. possibly due to a hardware error. /cdrom/casper/ only error i see

Not Sure

New member
Nov 25, 2020
2
0
4
21
I'm using a Sandisk cZ43 32GB with a YUMI multiboot to try out different distros on a Latitude E5570 with a LITEON CV3-8D512-41 SATA 512GB SED (T89410C)
half a dozen others were successfully livedemoed/installed/removed.

Both Regular and OTS versions of 19.xx and 20.xx succeed as live demo but fail install with seemingly exact same error log.

parsed out ERROR entries are as follows:

Code:
[ERROR distinst:ffi/src/lib.rs:48] libdistinst: pointer in FFI is null
[ERROR distinst:ffi/src/lib.rs:48] libdistinst: pointer in FFI is null
[ERROR distinst:ffi/src/lib.rs:48] libdistinst: pointer in FFI is null
[ERROR distinst:src/installer/steps/initialize.rs:28] config.squashfs: No such file or directory (os error 2)
[ERROR distinst:src/installer/steps/initialize.rs:39] config.remove: unable to open file at "/cdrom/casper/filesystem.manifest-remove": No such file or directory (os error 2)
[ERROR distinst:src/installer/state.rs:37] initializing error: unable to open file at "/cdrom/casper/filesystem.manifest-remove": No such file or directory (os error 2)
[ERROR distinst:src/installer/mod.rs:298] errored while installing system: unable to open file at "/cdrom/casper/filesystem.manifest-remove": No such file or directory (os error 2)
[ERROR distinst:ffi/src/lib.rs:48] libdistinst: pointer in FFI is null
[ERROR distinst:ffi/src/lib.rs:48] libdistinst: pointer in FFI is null
[ERROR distinst:ffi/src/lib.rs:48] libdistinst: pointer in FFI is null
[ERROR distinst:src/installer/steps/initialize.rs:39] config.remove: unable to open file at "/cdrom/casper/filesystem.manifest-remove": No such file or directory (os error 2)
[ERROR distinst:src/installer/steps/initialize.rs:28] config.squashfs: No such file or directory (os error 2)
[ERROR distinst:src/installer/state.rs:37] initializing error: unable to open file at "/cdrom/casper/filesystem.manifest-remove": No such file or directory (os error 2)
[ERROR distinst:src/installer/mod.rs:298] errored while installing system: unable to open file at "/cdrom/casper/filesystem.manifest-remove": No such file or directory (os error 2)
[INFO distinst:ffi/src/installer.rs:188] Install error: unable to open file at "/cdrom/casper/filesystem.manifest-remove": No such file or directory (os error 2)
(unabridged if needed: https://pastebin.com/uErj7egw will expire in 6 months)

Clean (full erase) installation choices are all defaults, except i opted for no encryption since this is a trail purpose for now.

it seems that the logger thinks unmountable cdrom is the issue.
the laptop doesn't have a cdrom.

poking around in threads i noticed that enabling EFI is suggested.
it was disabled before so i enabled it.
Secure boot was already disabled.

but the error log did not change one bit.

any ideas/suggestions are appreciated.
 

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,842
307
30
www.patreon.com
That error is usually indicative of a bad write. Pop is a hybrid ISO and requires dd to burn it correctly. Either Etcher, or Rufus in dd mode, should get the job done.
 
  • Like
Reactions: Not Sure

Not Sure

New member
Nov 25, 2020
2
0
4
21
thank you. Rufus image worked.

to anyone else stumbling upon this thread and still wishing to be able to multiboot,
I found additional details here:


this tip in particular seems promising
Mostly, this error occurs because of the fragmentation of the ISO file, so, before adding it to YUMI to create the bootable USB drive, defragment it with this tool called wincontig.
cheers
 

Members online

No members online now.

Latest projects

Forum statistics

Threads
1,423
Messages
6,511
Members
1,408
Latest member
nazar2sfive