• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question Beginner Installing unmet dependencies that are "not installable"

QuesterLEJ

Member
Mar 28, 2019
49
3
11
38
Hello,

I'm attempting to install the Folding@Home client using the installation guide here. However, I'm running into a very annoying (yet I'm sure very common) issue installing dependencies for the various packages. Pop!_OS (19.10 in my case) complains that a dependency is "not installable," but no sooner do I find and install it manually than I discover it needs another one. Is there a better, faster, and less annoying way to install dependencies than having to search for each one manually if they're not in the standard repositories the system has access to by default? As a relatively new Linux user, I can't help but think I may be missing something.

Luke
 

ParanoidNemo

Member
Mar 1, 2020
36
6
6
32
if I have understood your problem correctly the answer is no. if the deps are not in the repo you have to manually search and install for those. the only solution that came to my mind is to add a repo that contain all the deps (if exists) or use a flat pack/snap of the main software (always if exists) so that all the needed packages should be included in it.
 

QuesterLEJ

Member
Mar 28, 2019
49
3
11
38
if I have understood your problem correctly the answer is no. if the deps are not in the repo you have to manually search and install for those. the only solution that came to my mind is to add a repo that contain all the deps (if exists) or use a flat pack/snap of the main software (always if exists) so that all the needed packages should be included in it.
Thanks for the advice. You did indeed understand my question. My issue in installing the Folding@Home client is that it requires certain dependencies, some of which require their own dependencies, some of which require their own dependencies, and so on and so forth seemingly ad infinitum. It's obviously very tedious and confusing to have to go down the hierarchy of dependencies and keep track of what needs what, where one is in the process, and such. As a new Linux user, I thought there was probably an easier way to accomplish this that would save me much frustration and confusion, but from what you said, there's not (short of a snap or flatpak).

All I wanted to do was to set up and administer a Folding@Home team for System76 fans and Pop!_OS users so those interested could pool computing resources in this time of COVID-19 and afterward, as suggested here. But the software (in particular the control center, the client's GUI) is proving more trouble than it's worth to get working. I'll contact the F@H team and ask them about a flatpak or snap, but I welcome any other advice too.

Luke
 
I just went through the process of setting up folding at home on a new Pop!_OS system, and had a little trouble as well. The issue you're mentioning I think is due to the fact that the .deb for FAHControl requires either python-gtk2 or python-gnome2, neither of which appears to be available with the standard Pop!_OS repositories. I have yet determine how (or if) I'll address that issue but I was able to get the client itself running fine by stealing a bit from the Arch User Repository (AUR) folding at home package.

I downloaded and installed the fahclient_***.deb from https://foldingathome.org/start-folding/, this worked fine for me, even thought the fahcontrol one didn't. I think I just ran sudo apt install ~/Downloads/fahclient*

I modified the /etc/fahclient/config.xml to my liking and then I wanted to set up daemons, so I grabbed the file foldingathome.service and installed it at /etc/systemd/system/ (I ultimately had to comment the ExecStartPre line, though, and do the steps in the next paragraph). Since I have an Nvidia GPU I did the same with foldingathome-nvidia.service (which ultimately required me to install nvidia-modprobe and clinfo).

It looks like the user fahclient was auto-created, so I change the service files (foldingathome.service and foldingathome-nvidia.service) to change all references of fah to fahclient and then ran sudo chown fahclient:fahclient /etc/fahclient/ to made sure it had access to the configuration like the ExecStartPre line was trying to do. I did this the other way at first (creating and using a fah user) but I ran into some weird issues doing it that way.

In order to get OpenCL to work I installed ocl-icd-opencl-dev. For CUDA I'm not sure if I had to but I installed system76-cuda-latest and opencl-icd.

After that I believe I was able to foldingathome-nvidia.service and then foldingathome.service without problems. I fortunately had another (Arch) system with FAHControl installed that I could use to connect remotely and verify everything was working, but you should be able to monitor it by looking at /var/log/foldingathome/log.txt or by running either systemctl status foldingathome or (for more history) journalctl -u foldingathome.

Hope this helps!
 
Last edited:
After some digging it seems that what's ultimately happened here is that Ubuntu has removed support for Python 2 and as a result FAHControl is somewhat dead in the water on systems using Ubuntu 19+ or derivatives (like Pop!_OS).

I tried getting a little creative without much luck. Fortunately, it looks like the Folding @ Home team is aware of all this and is testing a version with Python 3, so it's possible a version will be released soon that will resolve this.
 
  • Useful
Reactions: derpOmattic
Wanted to report back on a few changes I've made in the past week. I updated my first response above with some refinements I've made as I've done additional testing to make sure things are stable.

I also determined that idle detection appears to be broken on Linux, so for those that want Folding at Home to pause when their PC is idle, I wanted to share the solution I put together for that.

I created a script /opt/fah/fah-idle.sh (location doesn't really matter too much as long as the fahclient user has access):

Bash:
#!/bin/bash

# adapted from https://github.com/FoldingAtHome/fah-issues/issues/1218#issuecomment-605615376
while sleep 10; do
    if loginctl list-seats --no-legend | xargs -rn1 loginctl show-seat --property IdleHint --value | grep -qF no; then
        echo "System not idle, pausing."
        FAHClient --send-pause > /dev/null
    else
        echo "System idle, unpausing."
        FAHClient --send-unpause > /dev/null
    fi
done
Then I created the following systemd service at /etc/systemd/system/foldingathome-idle.service to run the script (and keep it alive):

Code:
[Unit]
Description=Folding@Home Hack for Idle Setting
After=foldingathome.service

[Service]
Type=simple
User=fahclient
WorkingDirectory=/opt/fah/
ExecStart=/opt/fah/fah-idle.sh
Restart=on-failure

[Install]
WantedBy=default.target
With this setup things have been working smoothly. Hopefully this will all be resolved in future versions of the Folding at Home client, but this got the stuff that was important to me working well enough in the meantime.
 

Members online

No members online now.

Latest projects

Forum statistics

Threads
694
Messages
3,217
Members
605
Latest member
lehjr