• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Happy New Year!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Kernel options? Help!

JeansenVaars

New member
Oct 22, 2019
11
0
4
31
Hello!

I have read Kernel Options article but it isn't clear to me.
I've installed Pop OS alongside Windows in EFI mode. However POP OS did not use GRUB, so any kernel setting and update-grub2 calls don't do anything.

I basically need to add `acpi_osi=! acpi_osi='Windows 2009'` as `GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2009' quiet splash"` so my laptop airplane mode works normally (WIFI dies and goes to airplane mode after suspend, so I need this fix).

So I can't clearly find how to do this in this systemd init mode.

Thanks!
 

JeansenVaars

New member
Oct 22, 2019
11
0
4
31
I think I've got it. Thanks!


Code:
root@pop-os:/home/saif# cat /proc/cmdline

initrd=\EFI\Pop_OS-c6d0d9ee-0b73-47bd-b6aa-9078b1644751\initrd.img root=UUID=c6d0d9ee-0b73-47bd-b6aa-9078b1644751 ro quiet loglevel=0 systemd.show_status=false splash acpi_osi=! acpi_osi='Windows 2009'
 

JeansenVaars

New member
Oct 22, 2019
11
0
4
31
Hi @mmstick, it is not working :( even though I see the line added in /proc/cmdline , airplane mode button is not working so it must not be reading it.

This worked back in Ubuntu's grub so something's different here
 

mmstick

Member
System76 Staff
Founding Member
Dec 15, 2018
208
32
20
26
Denver, Colorado
If that's what `/proc/cmdline` states, then that's what was set. Was that Ubuntu install of the same version kernel? You may need a different workaround for a newer kernel.
 

JeansenVaars

New member
Oct 22, 2019
11
0
4
31
If that's what `/proc/cmdline` states, then that's what was set. Was that Ubuntu install of the same version kernel? You may need a different workaround for a newer kernel.
It was Ubuntu 19.10, also tried on Fedora 30
 

Members online

No members online now.

Latest projects

Forum statistics

Threads
506
Messages
2,373
Members
435
Latest member
leonardobd