• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Multi Monitor setup question

Nezmin2

Member
Feb 20, 2021
34
0
6
52
Idaho
Hey Guy,s
Quick question, as I am new to POP OS I am finding some things that confuse me, like the Multi monitor setup. I have two monitors. My right monitor is my primary. When I boot up, I have to go into NVidia config and reposition my monitors and reset the resolution and refresh every time. How does POP OS work to set up the monitors so that I do not have to reset this every boot up.

Thanks...
 

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,904
324
30
www.patreon.com
I've heard of this before. NVIDIA can cause all kinds of trouble with Linux due to their lack of proper Linux kernel support. I would have to dig around like you because I've never had NVIDIA. I have intentionally avoided it to have stable Linux machines. If I get some spare time I'll poke around. I was hoping someone with NVIDIA knowledge would step up.
 

Nezmin2

Member
Feb 20, 2021
34
0
6
52
Idaho
So, I tried hard coding xorg.conf using nano with the following:

Code:
Section "Monitor"
### Monitor Identity - Typically HDMI-0 or DisplayPort-0
    Identifier    "DP-0"

### Setting Resolution and Modes
## Modeline is usually not required, but you can force resolution with it   
Modeline "1920x1080" 172.80 1920 2040 2248 2576 1080 1081 1084 1118
    Option "PreferredMode" "1920x1080"
    Option        "TargetRefresh" "239.76"

### Positioning the Monitor
## Basic
    Option "LeftOf or RightOf or Above or Below" "DisplayPort-0"   
## Advanced
    Option        "Position" "0 1"

## Disable a Monitor
     Option        "Disable" "false"

### Monitor Identity - Typically HDMI-0 or DisplayPort-0
    Identifier    "HDMI-0"

### Setting Resolution and Modes
## Modeline is usually not required, but you can force resolution with it   
Modeline "1920x1080" 172.80 1920 2040 2248 2576 1080 1081 1084 1118
    Option "PreferredMode" "1920x1080"
    Option        "TargetRefresh" "60"

### Positioning the Monitor
## Basic
    Option "LeftOf or RightOf or Above or Below" "DisplayPort-0"   
## Advanced
    Option        "Position" "1 0"

## Disable a Monitor
     Option        "Disable" "false"
EndSection
It didn't work either.
 

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,904
324
30
www.patreon.com
Your xorg.conf looks OK to me, but maybe @evertiro can double check it?

Maybe a basic question to ask at this stage, but I'm going to just in case: Do you have the "Multimonitors Addon" GNOME extension installed? It doesn't exactly have the setting you're looking for, but it might prevent your system from hijacking the config. idk - worth a shot.

I have noticed on the odd occasion that I've needed to move the screens manually in Settings. What I mean by that is, despite choosing which is primary I have to "mouse drag" the display to the correct position. It actually says you can do that right above the area, but some people don't realize.

Additionally, sometimes multi monitors can benefit from turning HiDPI daemon off.

I know these things don't exactly sound like they're associated, but I'm just throwing some common fixes out there in case you haven't tried. You've been at it a LONG TIME. Sorry, I'm kind of useless with NVIDIA.
 

Nezmin2

Member
Feb 20, 2021
34
0
6
52
Idaho
Your xorg.conf looks OK to me, but maybe @evertiro can double check it?

Maybe a basic question to ask at this stage, but I'm going to just in case: Do you have the "Multimonitors Addon" GNOME extension installed? It doesn't exactly have the setting you're looking for, but it might prevent your system from hijacking the config. idk - worth a shot.

I have noticed on the odd occasion that I've needed to move the screens manually in Settings. What I mean by that is, despite choosing which is primary I have to "mouse drag" the display to the correct position. It actually says you can do that right above the area, but some people don't realize.

Additionally, sometimes multi monitors can benefit from turning HiDPI daemon off.

I know these things don't exactly sound like they're associated, but I'm just throwing some common fixes out there in case you haven't tried. You've been at it a LONG TIME. Sorry, I'm kind of useless with NVIDIA.
Thanks, I will look into these.
 

Nezmin2

Member
Feb 20, 2021
34
0
6
52
Idaho
So it turns out that the new Gnome (at least for me, as I am not used to it) has a Display setting. I had it configured wrong. Once I reconfigured and rebooted, everything works as desired. I guess this is why I post in Newbie Corner...lol
 

Nezmin2

Member
Feb 20, 2021
34
0
6
52
Idaho
Yes...

So after digging all over the web, I found that the tool for this was built into PopOS by default. I made the change in the settings as shown in the screenshot, rebooted, and everything worked as desired. When I opened the NVIDIA server config, it was set as I had setup the display settings in the Gnome Settings.

I hope that this helps others.

Thanks...
 

Attachments

Members online

No members online now.

Latest projects

Forum statistics

Threads
1,486
Messages
6,712
Members
1,433
Latest member
ducky