• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question No Grub showing after switching from Kali (dual boot)

johhnry

New member
Dec 10, 2019
2
1
4
21
Hi guys,

I've recently switched from Kali Linux to Pop!_OS (it's a nice distribution btw) as my main Linux distribution and I have a dual boot with WIndows 10.
Everything was working fine before and I installed Pop!_OS with this partition scheme (see attached file).

Capture d’écran de 2019-12-13 00-31-30.png


During the installation I selected my /boot partition (/dev/nvme0n1p1 ESP), / , /home and /swap and now my computer is directly booting into Linux during startup. So I don't see any Grub menu (but I can still boot into WIndows by pressing F6).

I am using UEFI and this is the output of some commands :

Bash:
~$ efibootmgr
BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,0001,0000,0002
Boot0000* Windows Boot Manager
Boot0001* kali
Boot0002* Linux Firmware Updater
Boot0004* Pop!_OS 19.10
Why do I keep seeing Kali in the Boot options?

And then updating grub is normal :

Bash:
~$ sudo update-grub
[sudo] Mot de passe de ******** :
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.3.0-22-generic
Found initrd image: /boot/initrd.img-5.3.0-22-generic
Found linux image: /boot/vmlinuz-5.3.0-20-generic
Found initrd image: /boot/initrd.img-5.3.0-20-generic
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done
I don't really know about Grub and booting process under Linux so any help would be great !

Thanks in advance.
 
  • Like
Reactions: 404usrnmntfnd

evertiro

Keymaster
Developer
Founding Member
Nov 21, 2018
253
62
20
Denver, CO
evertiro.com
It should be noted that Pop doesn't use Grub on machines that support EFI. @johhnry if you're still having issues, hit me up on Mattermost and I'll try to walk you through getting up and running.
 

Members online

Latest projects

Forum statistics

Threads
876
Messages
3,972
Members
839
Latest member
amarkovits