• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question Pop!_OS 20.04 not fully working with Radeon RX 5500XT

dbidwell94

New member
Sep 18, 2020
4
1
4
26
Bremerton, WA, USA
Let it be known: I am not gaming on Pop!_OS. I use it for my development work for web development. However, there are certain programs (Flatpak for the most part I believe) that has very unusual screen artifacts. Most notable: Pop! Shop's version of VS Code, Pop! Shop's version of zoom, OBS Studio, Pop! Shop's version of Slack.

I did not have these errors when I was using my IGPU (Ryzen 5 2400G), but as I now have dual monitors, I needed a discrete graphics card to support them. I have tried to re-install Pop!_OS 20.04 and the same issues happen. I installed vanilla Ubuntu 20.04 and the issues went away.
That nastiness below is what I see in the applications. Once again, it's only certain applications. I also tried to install official Radeon drivers but they are not compatible with Pop!_OS, only Ubuntu (for some odd reason). Any help at this point would be great


nastygpuartifacts.png
 
Last edited:

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,548
254
30
www.patreon.com
Support for the 5500XT in the Linux kernel is still kinda new, so you would probably benefit from a newer kernel.

I'd back up my system using something like Timeshift. That way you can restore to a point if things go wrong. I don't have AMD, so I'm only suggesting what I've observed in the community. You can do your own research, but I'd start at around 5.7.19, then work my way up to 5.8 and so on until it seems to work better. Apparently, it's easier to proceed to newer kernels with that tool than it is to regress.
 
  • Like
Reactions: dbidwell94

dbidwell94

New member
Sep 18, 2020
4
1
4
26
Bremerton, WA, USA
This is gonna be a difficult pill to swallow. This is my main development machine: so I really hope messing with the kernel won't screw things up. Luckily, github is a thing.. :ROFLMAO:
 

kira

Member
Sep 4, 2020
104
11
11
33
I hoped it would work, but I'm now running 5.8.0

I suppose you bought that card because is cheap, but it is "meant" for 1080p gaming..
Vega 56, Vega 64 or Radeon VII are suitable for production/web development
Take a look, even in gaming..
Screenshot from 2020-09-19 13-05-14.png


Like @derpOmattic said it's still new.
Official Radeon drivers is a no go in linux, maybe in windoze.. With AMD-Radeon is like, the older it is the better it performs Try a lighter distro ! You said it yourself "I installed vanilla Ubuntu 20.04 and the issues went away" .
 

Members online

No members online now.

Latest projects

Forum statistics

Threads
1,199
Messages
5,520
Members
1,246
Latest member
Moonzenith