• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Pop shop not opening. I don't understand why

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,832
305
30
www.patreon.com
Try and open it with terminal. Type io.elementary.appcenter and hit enter. If that launches it, it will help to know what is wrong.

Some questions for you;
Did you modify the system?
Have you installed, or are using, a non-default desktop environment?
Did you install another package manager or software shop?
Do you still have pop-shop, pop-desktop, pop-default-settings and pop-session installed? Check with apt policy <package>.
 

nick67

New member
Jul 12, 2020
6
0
4
53
Hello.

I have upgraded from 19.04 to 20.04. All went swimmingly except pop-shop not opening. I am using a Dell Latitude E5500. I entered the apt policy command, and it returned this;

<Installed: 3.3.0pop0~1589405854~20.04~72b0ae9
Candidate: 3.3.0pop0~1589405854~20.04~72b0ae9
Version table:
*** 3.3.0pop0~1589405854~20.04~72b0ae9 1001
1001 http://ppa.launchpad.net/system76/pop/ubuntu focal/main amd64 Packages
100 /var/lib/dpkg/status>

I would be grateful for any help


Regards
Nick.

Ps. Sorry if the terminal output is in the wrong format, not sure how you do it.
 

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,832
305
30
www.patreon.com
Some easy things first;
Try and open it with terminal. Type io.elementary.appcenter and hit enter. If that launches it, it will help to know what is wrong.

If that doesn't work, try re-installing it. sudo apt install --reinstall pop-shop.

Try this, and we'll go from there.
 

nick67

New member
Jul 12, 2020
6
0
4
53
Great.

I'll give these suggestions a try.

Thank you for your help.



Nick
 

nick67

New member
Jul 12, 2020
6
0
4
53
Hi there,

When I input io.elementary.appcenter, it takes me to the popshop. I can open and install programs with this method. I can open popshop with the GUI, but it will not install apps/programs.

Regards,
Nick
 

nick67

New member
Jul 12, 2020
6
0
4
53
Latest report,

I cannot even open popshop with the i.o elementary. appcenter command now. I get;
<23:22:20.874: Failed to load module "appmenu-gtk-module">

Looks like synaptic for me!

Nick
 

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,832
305
30
www.patreon.com
Another thing I've seen lately is to try and kill it. First find the PID number with pidof io.elementary.appcenter, then use kill <pidof-pop-shop-number>.

There seems to be a current bug which only effects some people's systems, where pop-shop is running already in the background. Killing it and restarting it seems to work. Hopefully the fix comes soon.
 

nick67

New member
Jul 12, 2020
6
0
4
53
Another thing I've seen lately is to try and kill it. First find the PID number with pidof io.elementary.appcenter, then use kill <pidof-pop-shop-number>.

There seems to be a current bug which only effects some people's systems, where pop-shop is running already in the background. Killing it and restarting it seems to work. Hopefully the fix comes soon.
Thanks for your help and advice.


Nick.
 

lengyang19

New member
Oct 25, 2020
1
1
4
21
Hello all, I was able to find a solution, although it may be a temporary one. Like stated above previously, It might be a minor bug only some people are encountering. I am still new to linux, so my solution to this isn't quite technical. But I was having the same problems as Nick, where I couldn't manually open Pop shop in the commands, nor could I kill the task and re-open it. I've tried uninstalling, and re-installing, but to no luck. But onto my solution, I was able to reopen Pop Shop by right clicking the Pop Shop icon, and clicking on the check for update option. When, and if, it opens a small window checking for an update, simply maximize the window. Doing so it allowed me to re-open Pop-shop. I closed out of Pop shop, and tried to re-open just to double check it was working and it was! Although it may be a bit rudimentary, it seemed to get the job done each time this has happened to me. Results may vary for everyone, but hopefully this helped. I've searched many forums, and had no other luck with commands. Most likely maybe this is just a minor bug.
 
  • Useful
Reactions: derpOmattic

chris9740

New member
Nov 9, 2020
1
0
4
18
Sweden
Another thing I've seen lately is to try and kill it. First find the PID number with pidof io.elementary.appcenter, then use kill <pidof-pop-shop-number>.

There seems to be a current bug which only effects some people's systems, where pop-shop is running already in the background. Killing it and restarting it seems to work. Hopefully the fix comes soon.
This worked for me, but after a while, the store disappears when I'm not using it, and I have to do this step again to be able to use it
 
  • Thinking
Reactions: derpOmattic

Members online

Latest projects

Forum statistics

Threads
1,416
Messages
6,486
Members
1,404
Latest member
awsumatt