• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Random blank screen when using external monitor

topfuel

New member
Jan 30, 2021
2
0
4
29
Hi

I have been using Pop OS! for at least 6 months. No problems until I started using it with an external display using HDMI. like 1 out of 3 times when I connect the hdmi display while laptop is running, screen goes blank and I have to force unclean poweroff by holding powerbutton. Same thing might also happen if I close lid to keep laptop running over night, when I open lid all is blank. And now for the first time it happened randomly after quiting a virtual machine that was in full screen.

I run version 20.10 running kernel 5.11, laptop is Thinkpad T14 AMD version, with ryzen 4750U.

Any ideas where to start troubleshooting? what logfiles to check?
 
Last edited:

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,842
307
30
www.patreon.com
The first thing to try when Pop glitches is a shell restart, done with alt + F2, then r and enter. However, you're saying a blank screen, so maybe try to login with a TTY. When the blank screen appears, try pressing alt + ctrl + F4. If you can login that way, it is possible to fix things, check logs and troubleshoot. If it goes well you can get back to the graphic environment by pressing alt + ctrl + F1.

If you need to reboot and check logs, here's a basic guide. There's a lot of information and official docs online about journalctl, but that post is enough to get you started.

Additionally, there are a couple of dumb things you can try that sometimes work. When you plug in the HDMI and it goes black, disconnect it and try again. Also, those times when the laptop doesn't wake properly, try closing the lid for a few seconds again, then open. Sounds weird, I know, but sometimes gdm just has to catch up.
 
  • Like
Reactions: topfuel

topfuel

New member
Jan 30, 2021
2
0
4
29
Thanks, it worked once now closing lid and pulling out cable and opening lid, then I could do alt+ctrl+f4 (did not work with hdmi attached). Second time it was totally locked and did not work completely, when i went back to graphic environment laptop screen was dead but external display showd picture. Login was on laptop so good luck. I was able to do clean shutdown by logging in from TTY at least.

dmesg | grep -i error gives this:
ACPI Error: No handler for Region [ECSI] (00000000aeafc8c0) [EmbeddedControl] (20201113/evregion-130)
ACPI Error: Region EmbeddedControl (ID=3) has no handler (20201113/exfldio-261)
ACPI Error: Aborting method \_SB.UBTC.ECRD due to previous error (AE_NOT_EXIST) (20201113/psparse-529) ACPI Error: Aborting method \_SB.UBTC._DSM due to previous error (AE_NOT_EXIST) (20201113/psparse-529)
ucsi_acpi: probe of USBC000:00 failed with error -5

That is worrying because I found this related to first line:
 
  • Thinking
Reactions: derpOmattic

Members online

No members online now.

Latest projects

Forum statistics

Threads
1,423
Messages
6,511
Members
1,408
Latest member
nazar2sfive