• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Question Solved Repair systemd-boot on Pop 20.04

Modern Drummer

New member
Oct 30, 2020
3
1
4
43
Hello guys, newbie here. Glad I've found this forum, hopefully you might be able to help me, if you have the patience and time.

So, I have a Ryzen 1800X system coupled with 32Gb DDR4 @ 3200MHz on a Asus Prime X370 Pro mobo and an RX580 4Gb GPU, with 3 sata SSDs and 1 HDD. Initially, my system had Ubuntu 18.04 on a Samsung 840Pro, Windows 10 on a Samsung 840Evo, and a 1TB Toshiba 2.5" hard disk for storage. When I switched to Pop OS, I decided not to mess up my Ubuntu install, so I used a third SSD that I had lying around, a Sandisk SSDPlus. BTW, Pop was installed with encryption ON. After having configured Pop to my preference, adding tweaks and customizations over the span of months, by following various internet tutorials, Pop has become my go-to OS for 99% of the time. I copied the Windows EFI boot files to the Pop boot folder, and added a 5 seconds delay when booting, in case I'd have to select Windows (for some gaming). As systemd cannot boot Grub-based distros, I left the Ubuntu SSD connected, and I would manualy select it in BIOS boot order, if needed to boot into it.

So, after a while, I figured I can lose the Ubuntu install, and needed to use the Sandisk for a different system. So I thought I could just move my Pop installation to the Samsung SSD. !!ALERT!! STUPID STARTS HERE!!:)) - I cloned my Pop OS install from the Sandisk SSD to the Samsung 840pro, using EaseUS Todo Backup from within Windows, with sector-by-sector clone. I thought that would work, having done it so many times for Windows cloning... I know, kick me in the balls. Firstly, should have used something like Clonezilla. Secondly, I found out that there are things to do beforehand, like changing UUIDs in the boot config files (I think) and probably some other steps that I'm unaware of. The result - neither the Sandisk or the Samsung SSDs would boot my Pop OS. I did not anticipate that the cloning process would change "stuff" on both the source and target drive. There is no longer an entry for Pop in my bios' boot selections. The fact that my Pop install is encrypted only adds difficulty to my situation, as far as I can see. Seems like something happened to the EFI boot partition.

I tried desperately to find internet resources on how to restore my boot settings, but I found info just for Grub. Couldn't find any systemd restore/repair tutorials. There is a system76 page about repairing bootloader / systemd, already tried, didn't work. Probably messed some more with that. I'm missing much knowledge when it comes to linux, or maybe the steps on that page don't work in my situation.. I'm freaking lost.

BTW, I'm not sure about the culprit being the EFI partition or systemd-boot. I might be completely off.

Anyway, I figure a little bit of background on my experience and knowledge would be in order: I basically switched to using Linux full-time since Ubuntu 18.04, but have been toying with various linux distros since the early 2000s. Never had the time to get knowledgeable enough with the terminal, so I decided to wait until Linux has matured enough GUI-wise to switch - when I could just be the "driver", but would not have to really become the "mechanic". Too busy a life for that, I guess. Anyway, I could never let go of Windows entirely, considering I needed it for work, to use DAW apps like Cubase, VSTs, and all that jazz.. I got really comfortable with Windows over the years, by having to optimize and tweak it quite a bunch for for DAW use.

Guys, any help would be immensely appreciated! Any thoughts, suggestions...just let me know. Thanks!

-moderndrummer
 
Last edited:

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,548
254
30
www.patreon.com
Wow, what a mess. :unsure:

You could try and rescue things in a chroot from USB. About half way down that page, but I guess it depends on it detecting anything. To be honest, I'd just fresh install. Do you have back ups?
 

Modern Drummer

New member
Oct 30, 2020
3
1
4
43
Thanks for replying. Yeah, i guess I could go down the reinstall route as a last resort, but I shouldn't have to at this time, because all I want is to restore my boot settings. Why take it from scratch for so "little" a thing? There's tons of online tips on how to fix grub, but nothing clear enough to follow for systemd. What puzzles me is that it seems like few linux users know how to approach systemd. Having an encrypted drive seems to add some extra pain at this point.

I think that the OS is ok and unaffected, it's just the boot files that are messed up. So, before considering reinstalling, I would try fixing the boot part, and after succesfully booting, I would check if my data is ok. If so, then problem solved. But atm, rescueing systemd boot looks like trying to figure out alien technology..

And no, I don't have a backup. That is still a to-do on my list for Pop OS. On Windows I do have backups... considering the years of habit. But it shouldn't be an issue, as the partitions haven't been altered in any way, so my data would just be there, right?

Still hoping some systemd guru would chime in.. Maybe I should try getting help from the Pop devs? Considering I didn't purchase hardware from them, I don't know if I would get any assistance..
 

Modern Drummer

New member
Oct 30, 2020
3
1
4
43
Nevermind, I fixed it by following system76's recovery guide, this time to a "T". It did take me 3 days... I was somehow repeating some commands and that's why it didn't work. Now that I've figured it out, I have to admit the guys over at system76 know what they're doing. Though, a total linux noob wouldn't be able to figure out by following system76's guide. They should specify that some commands listed in the decryption steps overlap with other commands in systemd-boot reinstall, bla bla.. Oh well, it can be marked as SOLVED!

Thanks, @derpOmattic for your input. Your reply somehow motivated me to take another look at system76's bootloader restore instructions. Cheers!
 
  • Winner
Reactions: derpOmattic

Members online

No members online now.

Latest projects

Forum statistics

Threads
1,199
Messages
5,520
Members
1,246
Latest member
Moonzenith