• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Solved Screen will not lock

gadgetboy

New member
Apr 2, 2020
23
6
4
Austin, TX
gadgetboy.org
I have a Lemur Pro. It's an amazing machine that has worked flawlessly since the day it arrived, even after upgrading to 20.04 - until last week.

The screen no longer locks after it goes blank or after system suspend. I'm also unable to lock the screen manually.

My Power and Screen Lock settings have not changed. (See below)

Since I regularly perform system updates, and new software is continuously introduced, I'm unsure how to best go about troubleshooting this issue.

These are the Gnome extensions I have installed. I've deactivated all of the Manually installed extensions with no success.

I would appreciate any suggestions or insights related to this problem. Happy to jump into Discord to chat in real-time.

1592399287374.png




1592399190371.png


1592399123421.png
 
Last edited:

derpOmattic

Pop!_Muse
Trusted User
Founding Member
Nov 23, 2018
1,091
164
30
www.patreon.com
If you can use the pastebin to post the output of journalctl -f and dsmeg right around the time it fails to suspend, we'll take a look. Meanwhile, what happens if you enter systemctl suspend into a terminal?
Being a System76 machine, opening a support ticket might be a faster way to get help.
 

gadgetboy

New member
Apr 2, 2020
23
6
4
Austin, TX
gadgetboy.org
Thanks for the suggestion, @derpOmattic. I found this in the journal:

Jun 18 12:50:00 zoboomafoo gnome-shell[2284]: Screen lock is locked down, not locking

Which led me to this search result:

Used dconf-editor and went to org.gnome.desktop
Saw that disable-lock-screen was enabled, and disabled it from there.
I used dconf-editor to toggle disable-lock-screen. I have no idea how that flag became set, but it's fixed.
 

Members online

No members online now.

Latest posts

Latest projects

Forum statistics

Threads
857
Messages
3,908
Members
819
Latest member
trinity