• Pop!_Planet is still very much under development. Data for the wiki is being sourced from the Arch Linux and Ubuntu wikis, along with a bunch of completely unique content specific to Pop!_OS, and sourcing, converting and updating that content takes time; please be patient. If you can't find what you're looking for here, check the Arch Linux and Ubuntu wikis.
  • Welcome!

    I'll get straight to the point.

    When I started Pop!_Planet, I launched it because I saw a need for a centralized community for Pop!_OS. To be frank, I never expected the level of popularity it has achieved. Over the last year, we have gone from under 50 users, to almost 400 users. That's awesome! However... it also comes with a downside. We are rapidly running out of disk space on our server, and the bandwidth costs go up every month.

    Pop!_Planet is not affiliated with System76 in any way, and is funded completely out of pocket. From day one, I said that I'd never use on-site ads (I hate them as much as you do), so the only monetization we get is through donations. Right now, the donations we receive don't even cover our overhead.

    I know that most users will ignore this message, and that's ok. However, if even a few of our users are willing and able to donate a few dollars to help offset our expenses, it would be greatly appreciated.

    Support Pop!_Planet

    Thank you for your time,

    Dan Griffiths
    Pop!_Planet Founder

Unable to update my system ( Main issue libc6:i386 package)

ashwath98

Member
Aug 5, 2020
15
0
9
23
I'm trying to update my system to get 21.04 but I'm facing some issues when trying to update

on running sudo apt upgrade
I get
Depends: libc6:i386 (>= 2.4) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).



on running sudo apt --fix-broken install
I get
dpkg: error processing archive /var/cache/apt/archives/libc6_2.32-0ubuntu3_i386.
deb (--unpack):
trying to overwrite shared '/usr/share/doc/libc6/NEWS.Debian.gz', which is diff
erent from other instances of package libc6:i386
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.32-0ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



on trying to install libc6 (sudo apt-get install libc6:i386)

I get

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libc6:i386 : Depends: libcrypt1:i386 (>= 1:4.4.10-10ubuntu4) but it is not going to be installed
Depends: libnss-nis:i386 but it is not going to be installed
Depends: libnss-nisplus:i386 but it is not going to be installed
locales : Depends: libc-bin (> 2.33)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).



Any help will be really appreciated I'm kind of stuck here rn
 

KGIII

New member
Jun 20, 2021
13
2
4
63
Hmm... Have you tried adding i386 architecture?

Code:
sudo dpkg --add-architecture i386
sudo apt update
 

ashwath98

Member
Aug 5, 2020
15
0
9
23
same iissue
libatomic1:i386 : Depends: libc6:i386 (>= 2.4) but it is not installed
libbsd0:i386 : Depends: libc6:i386 (>= 2.25)
 

Members online

No members online now.

Latest posts

Latest projects

Forum statistics

Threads
1,495
Messages
6,733
Members
1,433
Latest member
denis_vasconcelos